Notifications
Clear all

MAHA LPS 13 project. Many questions

Page 4 / 4
(@devolkswagenman)
Member

I got the plugins working. And recalibrated the loadcell with a new made bracket for the weights because i had wrong power numbers. Now i have the problem when i go to do a power sweep with starting point at 2000 rpm the brake suddenly go to 100% braking. i don't know if it had to do with the PID settings. If so what is the best thing to do?

ReplyQuote
Topic starter Posted : 07/10/2020 3:51 pm
(@devolkswagenman)
Member

Changed the PID but i got still the same problem. I am running the latest software (beta) and firmware version.

ReplyQuote
Topic starter Posted : 07/10/2020 7:56 pm
(@admin)
Member Admin

What PID parameters are you using? Kp = 1, Ki = 0.5 and Kd = 0.05 are normally good starting points. 

Which brake mode are you running? If you still have issues, send me your saved options file and I will take a look, jostein@yourdyno.com

This post was modified 10 months ago by admin
ReplyQuote
Posted : 07/10/2020 8:36 pm
(@devolkswagenman)
Member

@admin

Kp=1,4

Ki =0,5

Kd =0.0 

When i install the older version 3.2.59 everything works fine. But then i use the tacho setting to got engine rpm. When using 3.2.94 i use the scantool plugin for rpm. It looks like an error when the brake needs to work. The probem is in all the different brake setup programs. manual, powersweep, etc.

Older software works fine. but i would like to use the obd scantool

ReplyQuote
Topic starter Posted : 07/10/2020 9:25 pm
(@admin)
Member Admin

OBD2 RPM is just used to set the gear ratio. You set it as before when holding the RPM steady, you just don't need to hold a specific RPM, any RPM will do. The standard RPM sensor is still in use as before. But I guess you knew that!

What do you have on "Ramp up brake to before run starts" (0 to say 30% is a good start) and what do you have on the "Brake Control Update frequency" (10 to 20 Hz is good). 

Send me your saved settings and I can take a look.

ReplyQuote
Posted : 07/10/2020 10:18 pm
(@devolkswagenman)
Member

Ramp up brake before run starts is at 0% and the frequency is 10Hz. I use the same settings in the older software as the last update. I also checked  the settings of the signal to operate the brake. I use 0-5 volt signal on a sportdivices brake unit. It feels to me like a bug or something. If the brake needs to work in the program it just goes to maximum and on that moment i see the connection with the youtdyno lost for a second. the older software works perfect with the backup of the settings of the beta version.

Some other thing i saw in the software. When i set the language to dutch you can't change te RPM setting of the roller/brake. The word is to long in dutch. but thats okay to me I would like to have te problem solved with te brake. I will send u a email with the settings that i use. 

ReplyQuote
Topic starter Posted : 08/10/2020 6:38 am
(@devolkswagenman)
Member

Today i had an idea. I have a RPM sensor for the CO tester that works with a pietso element. It is magnetic en you can put it on the engine and wil measure the frequency of the engine and calculate the RPM. I did some measurements with te scope on the signal output and i saw it is a 5 volt duty cycle signal. Is it possible to put that signal on the rpm input on the yourdyno box? What would be the suggention to connect it to eachother? On the output i have an 5volt signal to ground. And a earth connection. I would think:

earth to shield

ground to 0V

signal to signal.

But the RPM unit has his own power supply 12volts. When i put the ground together (rpm unit --> yourdyno box) it must be okay i think. Any suggestions? In the picture the output signal on the scope. 

ReplyQuote
Topic starter Posted : 08/10/2020 3:36 pm
(@devolkswagenman)
Member

When there is no RPM signal the output is 5 volt continious between ground and signal. 

ReplyQuote
Topic starter Posted : 08/10/2020 3:54 pm
(@admin)
Member Admin

@devolkswagenman,

I tested your settings and reproduced the issue. There is a bug: When Ki = 0 the PID does not work. 

Ki should not be 0, set it to something > 0 and the regulation works. 0.5 is a good starting point. I will fix the bug of course, but there is an easy workaround for now. I also recommend setting Kd to something low, like 0.05. 

Thanks for reporting this! 

The RPM signal in your picture does not look very stable, so it does not look like a suitable sensor. 

ReplyQuote
Posted : 08/10/2020 11:18 pm
(@devolkswagenman)
Member

@thdyno

Here you go! (Sorry for the late reply) 

ReplyQuote
Topic starter Posted : 16/10/2020 7:01 am
Thdyno liked
(@devolkswagenman)
Member

After change the method of calibrating te load cell I stil have problem with the HP numbers. Small cars up to 100 HP is no problem but when I have a car around 250HP there is about 30 HP difference. I use calibrated weights of 20KG but when I go above 80KG the I got a wight difference of more then 5KG on the software. I was wondering if the load cell of the MAHA is lineair enough for the yourdyno software. Does have MAHA a correction for this in their software or is the original load cell the problem? It is still the original one from the analog system that can measure 250HP max. I asked MAHA if they can sell me a new load cell from a LPS 3000 or MSR type dyno. What do you guys think about the solution? Or can I better make a bracket with the S type Loadcell or use the original Bar type from MAHA? in the picture the original Bar type load cell. 

This post was modified 8 months ago by devolkswagenman
ReplyQuote
Topic starter Posted : 23/11/2020 8:11 pm
(@devolkswagenman)
Member

This looks a good solution to me but the bar type is less work to make it work but I don't know if the bar type is lineair enough. 

ReplyQuote
Topic starter Posted : 23/11/2020 8:16 pm
(@canisius-chong)
Member Customer

@devolkswagenman

 

Hi, I have similiar project like yours. I have sportdevices PWS 3.3. Can I ask how your install yourdyno with sportdevices pws?

ReplyQuote
Posted : 31/05/2021 4:31 am
(@admin)
Member Admin

PWS 3.3 can you controlled by YourDyno. Just set the output to Analog (jumper inside the box plus in software) and connect 0V and OutB out from YourDyno to the control input on PWS 3.3

ReplyQuote
Posted : 31/05/2021 6:54 am
Page 4 / 4
Share:
Select your currency
EUR Euro