Skip to content


Clear all

RPM2 engine RPM measurement error??

4 Posts
2 Users
Posts: 50
Topic starter

Hi Jostein,


I haven't really tried to use measured engine RPM much until now and I'm having a problem.

The example I'm using is a 4 cylinder with a distributor ignition.   I put my pickup(s) on either of the -ve coil terminal or an inductive clamp on the coil's HT lead.  I set the pulse/rpm to 2 for a 4cyl, 4 stroke engine.

If i put the pickup on a spark plug lead and set the pulse/rpm to 0.5 I get the same results.


The Yourdyno RPM reads low when compared to my digital timing light and cars tachometers.

I did some testing and injected 80Hz at my pickup with a frequency generator.  It's connected to the RPM2 terminals via a sparkfun opto.  I measure 80Hz with my o-scope at the RPM2 terminals on the blue box but Yourdyno reports only 1621rpm and it should be 2400 for a 4cyl at 80Hz.

I can get it to read correctly if I input 1.4 pulses/rpm, but obviously this is not correct.
The RPM filtering is set to default, but the test signal is very clean anyway.


Am i overlooking something in my setup or is there a potential software problem?


Many thanks for your help.

Posted : 24/10/2023 10:02 pm
Posts: 1343
Member Admin


Set RPM2 to "Other RPM". Call this channel RPM Pickup or something. Turn on RPM Pickup in the Run window and see that it reads correctly.

Then you can use this RPM channel to set the gear ratio.

This post was modified 1 month ago by Jostein
Posted : 24/10/2023 10:27 pm
Posts: 50
Topic starter

Ahhh, thank you.  I had tried selecting 'Other RPM Channel' but when I tested I saw the tach at zero all the time.

I now know that I was looking at the engine RPM calc'd from roller speed at that time..doh!!.


Now I have selected "other rpm' and the 'coil pickup' tach is responding but it's pegged at max rpm regardless of the freq I inject or the pulses/rpm setting.

As an extreme test I injected 10Hz and set 80p/rpm and it still pegged at 8000rpm.  I'll keep fiddling - I'm getting closer......

Thanks again.

Posted : 24/10/2023 11:11 pm
Posts: 50
Topic starter

Ok i fixed it!

I switched to a digital gauge so I could see exactly what it was doing - and it was now correct, but the analogy gauge was pegged because I had configured it as 0-8, not 0-8000!  The gauge itself looked fine when displayed, but was pegged at anything over 8rpm! So stupid.


Thanks for your help.

Hopefully this post helps someone doing equally stupid things 🙂



Posted : 24/10/2023 11:26 pm
Jostein reacted
Select your currency